View Full Version : Custom Proxy Extension gives error when dragging to a Proxy

13 Mar 2014, 7:42 AM
Dear forum members,

I would like to add a custom Proxy to Sencha Architect 3. So I created a package with a custom proxy file + the necessary configuration files.

When I add this package to the Sencha Architect Extensions (folder C:\Users\<username>\Documents\Architect\Extensions) then the extension is successfully loaded in Sencha Architect. Even better the proxy appears in the Toolbox (Data > Data Proxies section).

However when I drag the proxy to a Store in the Project Inspector an error occurs. Error message is:
This definition has specified a className Navara.proxy.NavaraProxy that does not exist. Ensure that the className in the definition matches the className specified in package.json

I am sure that I specified the correct name, so it must be something in my packaging. Can some help me with this?

Thanks in advance.

Marinus Geuze

18 Mar 2014, 9:02 AM
at a quick glance, I believe you may have your required JS files in the opposite order of what you need. NavaraAPI.js is minified so I can't quite tell there, but it seems you would need proxy.js to load before NavaraProxy.js since it defines Navara.proxy, and then NavaraProxy.js defines Navara.proxy.NavaraProxy ... I think you just need to reverse the order of your requires. The "actual" class should pretty much always be the last one listed.

18 Mar 2014, 11:14 PM
Dear honest bleeps,

I added a new simplified version of the extension. Which only contains one class. This version gives the same error.

Maybe you can help me to see the problem.


18 Mar 2014, 11:37 PM
I don't think the file is attached - can you try again and I'll have a look?

19 Mar 2014, 12:06 AM
Sorry, i was not clear.

I replaced the original zip.

Because the other zip exposed to much detail.

19 Mar 2014, 12:19 AM
I just downloaded the updated zip file and tried it out. Your package.json is malformed -- JSON cannot have comments, and you also left a trailing comma, and some of your field names are nonstandard.

After making a few adjustments to your package.json, I opened Architect and your extension loaded. I added a generic Store, dragged out your Navara Proxy, and got no errors, seems to work fine!

The only thing I did notice is a failed attempt to load Navara/proxy.js - this is because your NavaraProxy.js contains: requires : ['Navara.proxy'] -- it's trying to load Navara.proxy, which isn't defined anywhere. You can fix that by including that file in the JS array of your package.json before NavaraProxy.js

Here is the adjusted package.json content:

"name": "NavaraProxy",
"description": "Navara Proxy",
"version": "1.0.0",
"type": "code",
"creator": "Navara",
"compatVersion": "1.0.0",
"architect": {
"compatFrameworks": [
"classes": [{
"definition": "NavaraProxy.Definition.js",
"className": "Navara.proxy.NavaraProxy",
"js": [
"css": [
"local": true,
"requires": []

21 Mar 2014, 6:41 AM
Dear honest bleeps,

Thanks for you answer. It is fixed now.

Thank you.