View Full Version : Editable Combo Box Bug

Arnav Sengupta
10 Dec 2013, 12:48 AM
I have the following problem with the editable combo box. I don't know if it's a bug or not, I had once posted in another thread in the forum but never got a response. Neither from stackoverflow. Hoping someone will address this or point out what I am doing wrong

I tried creating a Sencha fiddle link, but it appears to be working fine there. However I recreated the problem I was facing on my local system on the below mentioned jsfiddle link:


The issue is as follows,

Just in case, my steps weren't clear to reproduce the issue, I will reiterate, I missed one thing

Click on the factor level field and try loading the drop down(without typing anything in it). This works as expected.
Re-run the script. Type some random text in the field (without loading the dropdown before typing or letting it load while typing) and tab out.
Now again try to edit that field and load the drop down on that field, it doesn't load anymore

I have faced this on Chrome, Firefox, and IE 8 and above. I am using extjs 4.2

If I can find any sort of help or response it would be really helpful. I haven't been able to figure what's wrong, even after trying to debug on the browser. Doesn't show any errors.



10 Dec 2013, 12:38 PM
The reason it stops working is because the drop down becomes hidden forever. The drop down is still in the DOM but just set to visibility: hidden; for some reason. You could possibly call a menu.show() or something on triggerclick as a workaround?

Arnav Sengupta
11 Dec 2013, 1:43 AM
What I noticed is this happens only with ext js 4.2 and not other versions. Worked on 4.2.1 and also 4.1.1. And yes it occurred on fiddle.sencha.com as well (earlier I had tried on 4.2.1 and didn't realize). I haven't tried your workaround yet, but if this is happening on just 4.2, it surely is a bug, right?

11 Dec 2013, 8:45 AM
It does seem like a bug. Also the only way I got it to happen on your fiddle was to:

1. Type something into the field before the menu appeared and then
2. Use the tab key to go all the way to the next combo box (hitting tab 4 times).