View Full Version : JSBuilder Issues

24 Oct 2012, 12:58 PM
Hi everyone,

Not sure if this is the correct place to post this question, if not, sorry, point me in the correct direction.

I have downloaded the SDK and JSBuilder seperate as well and when I run the java JSBuilder2.jar I get a "could not find the main class: JSBuilder2.jar" error. I have tried on windows, mac and unix with the same error on all 3. I am probably doing something wrong but I am not sure what that is.

Does anyone have experience with this error?

When I install the SDK and try to run the JSBuilder it wants me to install the jsdb components to run. I have not installed jsdb yet. I was hoping to not have to install it if possible.


27 Oct 2012, 1:04 AM
jsbuilder shouldn't be used for Ext JS 4... if you are using 4.1.1a, 4.1.2a or 4.1.3 then you should use Sencha Cmd otherwise you can use the SDK Tools

31 Oct 2012, 9:05 AM
ok, I was trying to use the jsbuilder from the SDK. I thought CMD was only for compiling for mobile, etc. I will get that and give it a try.


James Goddard
31 Oct 2012, 11:44 AM
jsbuilder shouldn't be used for Ext JS 4...

ExtJS 4 is production. Sencha Cmd is beta. The sdk tools are beta.

Until Cmd is out of beta and working much better than it does now, Sencha should continue to support jsbuilder. There is no reason not to use builder with 4, and a lot of reasons not to use cmd in a production environment.

Mike, if it helps, this is the command line I use to run jsbuilder2 from linux:

java -jar builder/JSBuilder2.jar --projectFile ./myproject.jsb2 --homeDir .

and windoze:

java -jar %drivep%\builder\JSBuilder2.jar --projectFile %drivep%\myproject.jsb2 --homeDir %drivep%