View Full Version : Cannot See List Data in Preview

Simon C
25 Aug 2012, 6:57 AM

Please help, i have spent a load of my trial time with no results.

I can not seem to see the list data when previewing my app. I have tried my own, followed the data tutorial, nothing.

I loads ok in the IDE. i can see the data in the list in the IDE, but blank in preview. I have ticked autoload.

Please help. I was as good as buying architect, but having doubts now.



25 Aug 2012, 1:32 PM
Autoload ticked is good.

What type of data are you loading?

I found that XML data loaded when I changed the declaration from UTF-8 to ISO-8859-1. Don't know why but it helped. I'm using Chrome, so it shouldn't have made a difference there.

Simon C
25 Aug 2012, 2:24 PM

I am loading JSON data, it loads and displays in the development environment but not when I preview in safari. I have been searching the forums now for hours with no joy.

Am I missing something really obvious?

Failing so badly at the first hurdle does look good for continued use.

Should I be manually loading the data store? From where would I do this?

As you will have quessed I am very new to Sencha and am in the process of evaluating it.



25 Aug 2012, 2:49 PM
I'm in the same boat, trying to evaluate Sencha/Architect . Speed of progress is a little worrying.

I have found that using an Ajax Proxy gets the data into the Canvas but not the browser as I am pulling data across domains (different asp.Net app in LocalHost). Therefore I am using a JsonP Proxy which doesn't show me data on the canvas or in Chrome but I don't get errors in Chrome. When I click the link telling me the data cannot be used in this configuration, all the data I want is right there!

Have you tried Fiddler in order to check headers etc? www.fiddler2.com

I have used it and can confirm that I have correctly formatted JsonP data, so I'm beginning to think this is a Sencha problem... but I've been wrong before! :">

I've also found that sometimes deleting stores and proxy's aren't always deleted (they hang around somewhere !) and browser developers tools show errors e.g. Resource not found: MyJsonPStore - I had deleted and replaced this with a regular Json store. Which makes it hard to track down bugs in your own code when Architect isn't cleaning up after itself.

Simon C
27 Aug 2012, 6:18 AM

Followed this link and it did the trick.




1 Oct 2012, 11:40 AM
I am having the issue with being able to view the list data in Architect, but not the browser. I took a look at the link that had you clear out the Sencha 2.0 directory but that did not do the trick. Is there something else I should try?

1 Mar 2013, 5:06 AM
Hi...I managed to display data using a webservice url in list with

navigation view in the designer but when it runs in browser it displays

empty then upon some reference for cross domain heard JSONP should be

used.. But not able to load data to store using jsonp.. It displays

error "unable to load data with specified configuration".. I loaded

model using rest proxy is ter any changes to be made..
Thanks in advance!!!