View Full Version : Sencha Tools Build Can't Find index.html

14 May 2012, 8:00 AM
I'm trying to build my application (which has been working fine) and now I'm seeing this:

[INFO] Resolving your application dependencies (http://mydomain.com/index.html)
[ERROR] Failed openning: 'http://mydomain.com/index.html', please verify that the URI is valid
[ERROR] Failed loading your application from: 'http://mydomain.com/index.html'.

However, that URL does work from the machine I'm building from. I can open Chrome and it pulls the app up perfectly. I can also wget from the command line as the same user and it works perfectly.

I'm not sure why it's failing all of a sudden. I've tried it with and without the 'url' entry in app.json and it fails both ways.

Anybody have any idea what I'm missing?

14 May 2012, 8:09 AM
are you able to ping that domain from the command line?

14 May 2012, 8:13 AM
Yes, and I've verified that it is pinging the correct IP address.

14 May 2012, 8:15 AM
Do you have wget or curl installed? could it be a proxy issue?

14 May 2012, 8:17 AM
A little more info:

This is my workstation. It's running OSX Lion and the pages are being served by the built-in Apache. I'm using a virtual host config to handle the domain and the domain name is being resolved to my machine's IP address (not by an entry in the hosts file.

I have tried using the loopback address as well, but it didn't make any difference.

The odd thing is, this was working a few days ago which makes me wonder if it's something that I've done during continued development work on the app. The app, BTW is working perfectly. It just won't build for production.

I also tried this on my Fedora development box and got exactly the same results with the Linux version of the build tools...

14 May 2012, 8:21 AM
It also just occurred to me that I may have put this in the wrong forum...sorry about that.

14 May 2012, 9:00 AM
OK. are you running the sencha command tools from the docroot of your app? Btw, I've used SDK Tools 2.x since b1, and have not had this issue in OS X using Apache. :-\

14 May 2012, 9:38 AM
Yes, docroot. And, as I said, it was working just fine a week or so ago, which is why I'm starting to wonder if it's some change I've made to the app's files. I hadn't had any problems with it, either.

Here's the full output:

[INFO] Deploying your application to /Users/username/Sites/myproductiondomain.com/html
[INFO] Copied sdk/sencha-touch.js
[INFO] Copied app.js
[INFO] Copied resources/css/app.css
[INFO] Copied resources/images
[INFO] Copied resources/icons
[INFO] Copied resources/loading
[INFO] Resolving your application dependencies (http://mydeveldomain.com/index.html)
[ERROR] Failed openning: 'http://mydeveldomain.com/index.html', please verify that the URI is valid
[ERROR] Failed loading your application from: 'http://mydeveldomain.com/index.html'.

17 Jun 2012, 11:42 PM
Hey, did you find answer to this problem? I ran into the same problem after successfully building the application many times before.

18 Jun 2012, 12:28 AM
Ok. Seems like problem was block of javascript that I had added to the index.html. I don't know why it was causing this problem but commenting it out fixed the problem.