View Full Version : Sencha Architect 2 problem with proxy

29 Apr 2012, 3:04 PM
I installed Sencha 2 Architect and am unable to get past the software registration screen. I'm behind a proxy and have manually entered the correct details. I know they are correct because installing Titanium Studio worked without a hitch. Where to now?

3 Jul 2012, 8:43 PM
Same story here too. Please help. Using windows version.

10 Jul 2012, 5:47 AM
I followed the instructions from

(http://www.sencha.com/forum/showthread.php?177700-Unable-to-establish-internet-connection-to-begin-software-registration.)it's still not working! No matter what environment:

- Ubuntu 10.04 without proxy
- Windows 2008 Server with proxy
- Windows 2008 Server without proxy

What to do?

10 Jul 2012, 10:17 AM
We had a server outage this morning. Could you please try again and see if this is still an issue for you?

11 Jul 2012, 12:02 AM
Thanks! I got past the registration screen now (in an environment without proxy).

10 Aug 2012, 4:44 AM
I've been getting this same error this morning. Same issues or is something else going on with my setup?

11 Aug 2012, 4:20 AM
I checked and the servers are up and running.

13 Aug 2012, 6:24 AM
But doesn't seem to be working for those outside of your network (saw another user having the same issues on Friday)


13 Aug 2012, 11:25 AM
This does not appear to be an issue with Sencha server availability, at least in my case when trying to activate a new copy of Sencha Architect 2 (build 442)

1. On a Windows XP system located on a network behind a proxy firewall, attempting to startup Sencha Architect 2 (build 442) for the first time always fails with the message

"Unable to establish internet connection to begin software registration"

Simultaneous to this, on a separate XP system directly connected to the internet, initial startup works fine and the login screen is presented.

The HTTP proxy login needed in my case uses a Windows Domain formatted user ID, which is normally supplied in the form <domain>\<userid>.

I have tried various permutations within the Manual specification of the proxy screen, using both Auto Detect and Manual. In the Manual mode, I have tried using both the standard Windows format for the domain\username and password as well as UNIX format (escaping special characters with a backslash).

So, for example, for a domain of ACME, a username of jsmith, and a password of password!, if have tried the following:

ACME\jsmith password!
ACME\\jsmith password\!

2. I have validated connection to the Sencha activation server by using the method listed in the Sencha Architect 2.x: Help & Discussions / FAQ thread (I recieved a file called connection.php with the success message):

Open this link to check if your computer is able to establish a connection with our servers. If it's working correctly, it will show something like
{"success": true,"msg": "working"}

3. Question: Is it possible that contrary to the validation in #2, that my proxy firewall is blocking the connection to the Sencha server needed to perform the activation of the trial software? (Unfortunately, I do not have access to the firewall logs in order to answer this question.)

13 Aug 2012, 6:19 PM
It could be possible that it's allowing for port 80 but not for SSL

14 Aug 2012, 5:38 AM
I take it from your response that the username format that I was using (domain\user id) was the correct format expected by the Architect 2 proxy configuration screen.

The hypothesis that my firewall allows 80 but blocks 443 to a specific URL seems unlikely (though I would not rule it out).

To test whether my firewall is blocking 443 to your site for some reason, is there any possiblity that the existing test URL referenced in the FAQ (http://animator.sencha.com/api/d/connection/connection.php) could be extended to use https (https://animator.sencha.com/api/d/connection/connection.php) as well?

17 Aug 2012, 5:47 AM
It depends on the proxy. it's obviously an active directory domain controller situations. afaik Qt will pass the user info to the proxy as-provided.

NTLMv2 authentication is still an unconfirmed thing and likely that's what your environment is using.

if automatic/system settings aren't working, then your other option is installing a local proxy server that does the authentication (http://cntlm.sourceforge.net/)

working offline of course is the final option

20 Aug 2012, 8:22 AM
You were dead on with the NTLMv2 authentication. Installing a local proxy has solved my problem. Thanks for the help.

22 Aug 2012, 6:48 AM
You were dead on with the NTLMv2 authentication. Installing a local proxy has solved my problem. Thanks for the help.

Thanks for confirming gorgon. NTLMv2 is our nemesis right now and we're working to support it in the future.

22 Aug 2012, 7:40 AM
I just installed architect 2 and have the same issue with activating -- unable to establish internet connection ..

I am running on windows 7 64 bit enterprise edition. i also tried this on windows 2008 server but the same issue.

I cannot install local proxy. any other suggestions ?


23 Aug 2012, 8:39 AM
Yes we can generate you a license file.

email Architect (dot) feedback -at- sencha.com

ask them to help you get an offline license file.

4 Jun 2013, 4:15 AM
win xp, squid proxy
cannot connect

please help

5 Jun 2013, 10:25 AM
Email the above address to get a license.

25 Jun 2013, 1:25 AM
Installed Architect 2.2 on a 64 bit linux machine behind an http proxy.

On startup it reports:

Testing port 80 http Success
Testing port 443 https Fail

File '.local/share/Sencha/Sencha Architect 2.2/runtime/sdp-' contains:

[29592:29608:0625/104236:327614871293:ERROR:cert_verify_proc_nss.cc(744)] CERT_PKIXVerifyCert for www.sencha.com failed err=-8172

Proxy is not blocking connections on port 443.

When using firefox to check url 'https://www.sencha.com/api/connection.php', it complains about untrusted issuer authority (Error code: sec_error_untrusted_issuer). Adding a permanet security exception is a workaround for firefox but not for Architect.

Currently I'm using Architect 2.1 that probably is *not* using SSL connection.