View Full Version : GXT 3.0.0-RC classpath problem

2 Apr 2012, 11:32 AM
Hey guys, I spent about 3h today trying to solve this problem, but still w/o any success. I added gxt-3.0.0-rc.jar from the zip file to dependencies path and also to class path for run app. The project compiles w/o any errors (so it can see dependency), but when I start run-gwt-client, i'm getting the following error:
Unable to find 'com/sencha/gxt/ui/GXT.gwt.xml' on your classpath; could be a typo, or maybe you forgot to include a classpath entry for source?

Which indicates as i got insufficience of dependencie, or typo. I also tried to get GXT from sonatype repository, but there's only gxt-parent available and in that case there's nothing to ingerit.

Could you please give an adveise where to put my effort? Need to start completely new project basing on gxt 3.0, but this thing delays it.

(Using GXT 2.2.5 was causing no troubles at that point)

Colin Alworth
2 Apr 2012, 12:00 PM
If you are using maven, can you share the pom you are using? All of GXT is in maven central, see http://search.maven.org/#search%7Cga%7C1%7Cg%3A%22com.sencha.gxt%22 for the available artifacts. For a working sample project using RC, take a look at https://github.com/niloc132/SenchaConSnake.

If not using maven, can you explain what you mean by 'when I start run-gwt-client'? Is that an eclipse run configuration, and if so, is GXT on the classpath of that run config? If you added GXT 3 to the classpath after that run config was created, it might not have it by default.

2 Apr 2012, 12:36 PM
Hey, Collin!

Thank you for your reply!
We're using maven, but for deployed versions. For developing we're working with Grails 2.0 and GXT. This run-gwt-client comes from Grails. Currently I'm switching to IntelliJ Idea, but I also tried this with Eclipse. So yes, it's run configuration in Eclips (Idea). I provide the classpath for this run-gwt-client configuration. Tomorrow I'll try to play a bit taking in account what you said about classpath and configuration.

3 Apr 2012, 11:59 PM
So, finally the problem was in Grails BuildConfig, there should be a line

gwt.use.provided.deps = true

Then it takes in account all provided libs, because at some point it was not only with GXT.