View Full Version : Upgraded to build 309, rendered all of my previous projects unusable.

8 Mar 2012, 3:09 PM
I upgraded to Sencha Designer 2 build 309 today, and now it seems I am unable to load any projects I had built in any previous versions of Ext Designer or Designer 2. Every time I try to load a project, I get the following prompt:

"The project was built with a previous version of Designer, and needs to be upgraded. Is it OK to upgrade?

I click Yes, I get a message that the conversion was successful (why do I even need to convert a project created in a previous build of Designer 2?). I can see my project on screen for a brief flash, but when the process finishes, the project is empty. No applications, controllers, views, models, or stores.

Worse yet, the process seems to be permanent, as re-opening the project does not give me the chance to roll back the conversion or perform it again.

Be warned! Build 309 rendered my project unusable. "Thank God for source control", as one other user put it. In the meantime, I need to keep working, what should I do?

8 Mar 2012, 4:02 PM
If you must revert to an earlier build like 298, you can do the following.

Delete the 309 build .ion from the following location and then start the app.

Windows XP
C:\Documents and Settings\<username>\Local Settings\Application Data\Sencha, Inc\Sencha Designer 2.0\

Windows Vista/7
C:\Users\<username>\AppData\Local\Sencha, Inc\Sencha Designer 2.0\

~/.local/share/data/Sencha, Inc./Sencha Designer 2.0/

Mac OS X
~/Library/Application Support/Sencha, Inc./Sencha Designer 2.0/

Could you please share the project with us that will no longer open? > 309 will have a few critical fixes that may address your issues.

8 Mar 2012, 4:19 PM
I may have been unclear. The project will open, but it's entire contents have been blown away during the "conversion" process. I'm attaching the project, but I think the damage has already been done.

Follow-up question: can I rebuild a project from the exported JS files? I have the most current version of those, and they are my only hope of getting a working project again.

8 Mar 2012, 4:22 PM
Zip the entire directory up

8 Mar 2012, 4:23 PM
And be sure to include any hidden files... The only thing that should have happened in the "upgrade process" was to rename the hidden directory from .metadata to a normal directory named metadata.

9 Mar 2012, 6:52 AM
explore the project using cmd or terminal and see if a .metadata/ directory exists. If so then rename this directory to metadata/ (no dot) and reopen project

9 Mar 2012, 6:56 AM
I'm going to add an extra step to archive projects before upgrade.

Regardless please have your projects in source control so you can recover from these sorts of things. It's no excuse for the fail here but it's a must have practice.

9 Mar 2012, 10:07 AM
Hoping that you can provide the sample project that broke when upgrading to 309.

311 has been put out today but I'm not sure that it will resolve your issue.

9 Mar 2012, 1:07 PM
I was able to restore a working version of the project prior to 309, thanks with that.

309 converted the metadata folder, but my project was full of error messages and looked nothing like it did before conversion. 311 seems to have resolved the issue, but I still see errors about the formatting of some of my objects (could be my fault). At least my project looks and acts like it should.

I'm including the original project and .metadata folder in a zip.

9 Mar 2012, 2:52 PM
I downloaded your zip and unzipped it.

I needed to change the xdsBuild from "311" to 298 in a text editor. After doing that and opening it, the project seems to have upgraded fine.

Stephan Mercier
9 Mar 2012, 5:35 PM
I am using build 311 and when I open a v1 file, I get prompt to convert. But when the conversion is completed, the project views shows for a quick moment and then disapear. At that point, there is nothing under Views or any other section. Looking at the directory, I do not see any Metadata or .Metadata directory created. The converted project (xds) basically contains only the project settings (see attached file).

9 Mar 2012, 5:51 PM
Without the .metadata or metadata directory, we won't be able to help you that much.

Stephan Mercier
9 Mar 2012, 5:56 PM
As I said, once the conversion is done, there is no metadata or .metadarta directory, I went back to build 309 and the conversion is showing all my views properly. I attached my v1 project so you can try it.

12 Mar 2012, 8:53 AM
Does opening the v1 project and saving it in the new format succeed or fail?

It's working fine for me here...

Stephan Mercier
12 Mar 2012, 9:31 AM
I re-installed build 311 and downloaded the file (Start.xds) from the Forum and still get the same behavior. I have attached screen shots of what I see. The first screen shot shows is while the conversion is happening. THe second is once the converted project is loaded. Is there any log or anything I could do to help you help you with this? Thanks

Stephan Mercier
12 Mar 2012, 9:34 AM
To answer your question, when I save the resulting project, it says "Project successfully save", but the xds is like the example posted above in this thread.

12 Mar 2012, 9:54 AM
Hrm, try to save to a completely new directory?

Perhaps you are saving in the new file format as "metadata" directory into the same place where the old ".metadata" directory is and then the next time it opens it is getting confused?

I'm having no problems opening the v1 project and then saving it.

Stephan Mercier
12 Mar 2012, 10:32 AM
I restarted my computer, put the Start.xds alone in a brand new directory called test from the root and I get the exact same result, the project shows for a quick moment and then disapear. I have attached the content of the Sencha2 directory and the AppData directory. I am using Windows 7 Ultimate SP1.

12 Mar 2012, 11:17 AM
can you show me the directory your project is in (visual)?

also note you can't just move the xds file you have to account for the contents of the entire directory
/.metadata or /metadata after upgrade

Stephan Mercier
12 Mar 2012, 11:28 AM
Please remember that we are talking about a project that is currently under V1 and we want to convert it to V2. In V1, there was no metadata directory and the App directory was the Export directory and not part of the designer project per say. I can copy the XDS alone anywhere I want and open it with the V1 designer. Also, if I delete the xds-, I get back to the build 288 and, with that build, I can open the V1 project and it get converted properly from the single XDS file alone. And when I saved it back, all the V2 directories and files are created properly. Hope his helps.

12 Mar 2012, 11:32 AM

That is an issue other than I had been considering and could be very plausible bug! Looking into this.

22 Mar 2012, 9:44 AM
I am having the same problem!

I tried to open a 1.x designer file in build 311 and it did exactly what the others described. When it was done, the designer project file was empty and no metadata or .metadata directories were created. I then renamed the 311 .ion file and restarted the designer and declined to upgrade to the latest build. I then opened the 1.x project and it upgraded it perfectly. When I saved the project the .metadata folder was created. I then closed the designer, renamed the 311 .ion file back and restarted the designer and opened the newly upgraded project file. It properly renamed the .metadata folder to metadata and the project is working fine now.

There is definitely something wrong with the upgrade code in the 311 build.

--Stewart McGuire

22 Mar 2012, 9:57 AM

Would you be willing to send me your xds file?

22 Mar 2012, 11:59 AM
Here it is.


23 Mar 2012, 6:58 AM
This should work w/ next autoUpdate 320+

23 Mar 2012, 7:52 AM
Thanks. Looking forward to getting it! :)

25 Mar 2012, 6:15 AM
It's out

26 Mar 2012, 8:25 AM
I have a VERY small project with just a single tree panel in it.

When I try to open this file in 337, it does the same thing as older versions. It tells me it is an older xds file and it will create an archive first (which it does. I have attached the xds file to this post) then I get an error like the following:

TypeError: 'null' is not an object

Then the project is displayed and there is NOTHING in it!

--Stewart McGuire

26 Mar 2012, 12:49 PM
Yes this is a bug and I've got a fix which will be out this week. If you send me your file (PM for email) I can upgrade it for you so you don't have to wait until next auto update.

26 Mar 2012, 12:57 PM
That's ok. I can wait. That project didn't have much in it anyway and that particular class is still being developed using 1.2. I was just trying to upgrade it for testing purposes.

--Stewart McGuire

26 Mar 2012, 2:29 PM
thanks for reporting it

26 Mar 2012, 2:44 PM
I tested latest build version 341, with same errors I have had for a number ov buld version.
When opening a 1.2 version in 2.0 everything looks good to start with, all gui components are shown and then erros start to popup and the result is a blank project file.

Any hints for a resolution is very apresiated.

26 Mar 2012, 7:05 PM
willing to share your project? PM me if you don't want to post it publicly

27 Mar 2012, 12:59 AM
I have the same issue with all my project

28 Mar 2012, 11:39 AM
The next update will allow you to open these files correctly here is the client project


28 Mar 2012, 12:15 PM