View Full Version : [CLOSED] Unable to load data using the supplied configuration

27 Feb 2012, 9:29 AM
I encountered this error while doing the Designer 2 tutorial:

Unable to load data using the supplied configuration.
Open in Browser: data/cars.json

I can access the json file when I click the "data/cars.json" link in that message.

I'm using version 2.0.0 build 297. I tried this on 2 different boxes, one running Apache HTTP Server & the other IIS (both Windows XP).

I haven't seen this issue in the Designer 2 forums but I saw a nearly identical issue on the Ext Designer: Help & Discussion forum (http://www.sencha.com/forum/showthread.php?121378-Datastore-quot-Unable-to-load-data-using-the-supplied-configuration-quot) and I tried the following based on suggestions from that post but was unable to resolve the problem:

- Deleted the .localstorage file and then restarted Designer.
- Uninstalled Designer, deleted the entire "C:\Documents and Settings\[username]\Local Settings\Application Data\Sencha, Inc\Sencha Designer 2.0" directory and then reinstalled hoping to be able to change a proxy setting during the installation as indicated in the above post for the older version. There was no proxy setting that I could find either during the installation process or in any configuration dialog within the program itself.
- Changed the url prefix from http://localhost/carstore/ to the actual IP address.
- Tried various combinations of including/excluding leading/trailing slashes in the url prefix and the proxy url.

Any help is appreciated.

27 Feb 2012, 9:48 AM
I discovered the cause of this problem. There was a trailing space in the "root" property of the store's reader. Sorry for the false alarm.

27 Feb 2012, 9:54 AM
Thanks for the update.

27 Oct 2012, 12:29 PM

I have exactly the same problem but cannot find a blank or something else.
What can I do or check? Where can I find a detailed error log?


13 Dec 2012, 3:53 PM
Same problem for me. I´ve already checked everything. The error still remains.

7 Mar 2013, 8:24 AM
yo tengo el mismo problema por favor si alguien tiene una solución se lo voy a agradecer

14 May 2013, 11:51 AM
I have the same problem...json file type has been added to IIS. I have tried to find other solutions but to no avail. please help!