View Full Version : [FIXED] Sencha Designer 2 - Unable to sign in on Ubuntu "A communication error has occured."

31 Jan 2012, 12:33 PM
When I attempt to sign in with Designer 2 on Ubuntu, I get the error "A communication error has occurred".

I am able to sign in on my laptop which is running windows.

Has anyone else experienced this issue? Thanks!

31 Jan 2012, 12:41 PM
I tried both the 32- and 64-bit builds of Designer on my 64-bit Ubuntu 10.10 box, and I got the same error. I ran Designer 2 from the terminal, but I didn't see any error messages printed when the communication error occurred.

I previously registered Ext Designer 1.2 with the same Sencha user account on the same machine on the same network. I was able to register Designer 2 on a Mac on the same network with no problems. So it seems like it could be a Linux- or Ubuntu-specific problem.


31 Jan 2012, 1:52 PM
We've seen this problem on all platforms but have not determined how to reliably reproduce it.

Unfortunately it's not always reproducible if you try a few times it may actually register. Looking to get to the bottom of this.

2 Feb 2012, 10:28 PM
I got this problem too. It always happens on my 32bit ubuntu 10.04. Hope to see your solution soon.

3 Feb 2012, 6:17 AM
We believe that we've isolated this to a server issue and the ops team should have this resolved by tonight. Thanks for your patience.

8 Feb 2012, 9:25 AM
could you tell me when this problem gonna fixing ?? I have registred in sencha, but i cant siging to use sencha designer 2, it say "A communication has occurred" all the people has the same shhh...8-|


8 Feb 2012, 9:33 AM
On linux only there is an issue with the authentication going over SSL.

We are looking into it.

8 Feb 2012, 10:05 AM
I'm having the same issue on Linux as well trying to register. I'll keep an eye on this thread to see when it is fixed.


8 Feb 2012, 10:15 AM
on ubuntu 11.04

jj from francfourt germany

8 Feb 2012, 1:36 PM
Ubuntu 11.10 64bit

Any ETA yet? Really want to give this a shot.

8 Feb 2012, 10:53 PM
I'm having the same issue on Ubuntu 10.10 as well trying to register.Hope it will fixed as soon.....


10 Feb 2012, 11:32 AM
I've updated the installers for Linux and hope this relieves this issue. See new installers here http://www.sencha.com/forum/showthread.php?152941-Sencha-Designer-2-Beta-Download-links&p=666386#post666386

10 Feb 2012, 11:39 AM
Thanks Phil- that fixed it. Your first look video has been very helpful on getting me up to speed.


11 Feb 2012, 10:28 AM
Awesome I'm glad to hear it

16 Feb 2012, 2:54 AM
Awesome I'm glad to hear it
Hi Phil, i faced same problem, i'm using Mac OS 10.7.3, macbook pro, when will you fix Mac OS version?

21 Feb 2012, 12:41 PM
OS X should be working correctly. Are you behind any firewalls?

21 Feb 2012, 5:36 PM
Yes, i change a network and now works well, thanks phil. should because of company's firewall issue.

22 Feb 2012, 7:03 PM

23 Feb 2012, 9:32 PM
Hi, I need to know more about this problem, 'couse I'm under a proxy that don't admit plain text password, then i had to configure CNTLM proxy like a local proxy.
Any hint about SSL or something like that?

27 Feb 2012, 10:37 AM
sent a PM

19 Mar 2012, 10:07 AM
The same problem on Windows XP