View Full Version : XML form doesn't work

24 Oct 2007, 4:09 AM
I downloaded ext-2.0-beta1.zip, unziped it and uploaded to server. That's all.

What is wrong?

24 Oct 2007, 4:11 AM
Use firebug, when I click load, firebug reports this error:


<head><title>411 Length Required</title></head>

<body bgcolor="white">

<center><h1>411 Length Required</h1></center>




24 Oct 2007, 4:29 AM
I see... and it means that ExtJS doesn't send Content-Length (:|

24 Oct 2007, 6:37 AM
It is solved! :)

10 Dec 2007, 5:55 AM
It is solved! :)

I am trying to use the XML form example and am getting the 411 error (Length Required) on my xml-form.xml file showing up in firebug. What did you do to correct it.


10 Dec 2007, 8:35 AM
Did you verify that you're setting the correct content-type on the response?

14 Jan 2008, 12:58 PM
I ran into this same problem. In IE it works but Firefox gives me a "Length Required" error. What did you do to get it to work?

26 Jan 2008, 12:10 PM
When I ran into this problem I figured out it was the button config for the form. I was using the same config for 1.1 and it came up with this error. When I used 2.0 button config the error went away.