View Full Version : Sencha Touch and PhoneGap problem with builds - Xcode not referencing changes

5 Feb 2011, 3:02 PM
I have configured my STouch Phonegap project to have the www project subdirectory outside of the initial project directory so that I could make edits in an external editor (ColdFusion Builder based on Eclipse) for browser based debugging rather than alway running through the iPhone emulator.

Now even though I can see UI changes in the main application js source file I don't seem to be able to build these changes to show in the emulator. I have tried editing the source in xcode and saving to no avail. Also, touching the file and fiddling with the path type of the primary code folder (named 'remote').

I have also tried Clean All Targets and then rebuilt with no change in the behavior. Seems like it is still referencing an older version of the js source.

Any insights appreciated.

BC - resolved by renaming the web assets subdirectory to 'www' and now even splitting the project between web and other resources works fine.

9 Feb 2011, 11:04 AM
Moved to sencha touch help. Please post in the appropriate forum in the future ;)