View Full Version : [CLOSED-179] Grouped list throws error when scrolled up.

27 Jul 2010, 1:30 PM
This is a NEW bug introduced in v0.92. If you scroll a grouped list (Ext.List) up and when any group header disappears behind the top edge, the following error occurs:

Uncaught TypeError: Cannot call method 'show' of null. ext-touch-debug.js:15185

Here's the full stack trace:

Uncaught TypeError: Cannot call method 'show' of null. ext-touch-debug.js:15185
setActiveGroup. ext-touch-debug.js:15185
onScroll. ext-touch-debug.js:15264
fire. ext-touch-debug.js:2293
fireEvent. ext-touch-debug.js:1963
_scrollTo. ext-touch-debug.js:5919
handleScrollFrame. ext-touch-debug.js:6084
call. ext-touch-debug.js:8440

You can see the defect in the List example in Kitchen Sink app. It doesn't break the execution of the script, so to see it you need to have debugging tool running.


Jamie Avins
27 Jul 2010, 2:29 PM
Thank you for the report, we're looking into it.

28 Jul 2010, 4:10 PM
If I run http://www.sencha.com/deploy/touch/examples/kitchensink/ or the latest version on my local branch, I never see this error in neither Chrome nor Safari. Which browser / version did you get this error in?

28 Jul 2010, 6:03 PM
Ah yes, I ran it in Google Chrome Dev channel. It is fine in stable and beta. I apologize :)

Jamie Avins
29 Jul 2010, 9:35 AM
No problem, it seems that a few people are having this issue right now. Hopefully it's just a bug in the dev currently.